IMPLEMENTATION OF DHCP IN CISCO PACKET TRACER:

What is DHCP?

Dynamic Host Configuration Protocol (DHCP) is a networking management protocol used to dynamically assign an IP address to any new node or device entering the network. DHCP permits a node to be configured automatically, thereby avoiding the necessity to involvement by a network administrator. DHCP can be implemented on small local networks as well as large enterprises networks.DHCP runs at the application layer of the transmission control protocol/IP (TCP/IP) protocol stack to dynamically assign IP addresses to connected devices.It is a client-server protocol in which server manage a pool of unique IP addresses, as well as information about client configuration parameters, and assign addresses out of those address pools.

How to IMPLEMENT DHCP : -
1) Select  PCs ,  Routers and  Switches. 
2) Make all the necessary connections. 
3) Assign IP addresses , subnets and gateways.

COMMANDS: 
ROUTER 1:
Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface GigabitEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface GigabitEthernet0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if) #ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#interface GigabitEthernet0/1
Router(config-if)#ip helper-address 192.168.1.10
Router(config-if)#exit
Router(config)#

ROUTER 2:
Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet0/0
Router(config-if)#no ip address
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if) #ip address 192.168.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface GigabitEthernet0/1
Router(config-if)#ip address
% Incomplete command.
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#ip helper-address 192.168.1.10
Router(config-if)#exit
Router(config)#
Router(config)#interface GigabitEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface GigabitEthernet0/1
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
Router(config-if)#ip helper-address 192.168.1.10
Router(config-if)#exit


Comments

Popular posts from this blog

Configuring Open Shortest Path First Protocol:

Introduction to Cisco Packet Tracer

Configuring Static NAT in Cisco Packet Tracer